Axalto Egate (USB) Working on Solaris 10?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Axalto Egate (USB) Working on Solaris 10?

Palanisamy, Kandasamy (Kandasamy)
Hi,
 
    Does Axalto egate (Cryotoflex) USB smart card work on Solaris 10 with OpenCT and OpenSC?
I got OpenCT compiled on Solaris 10 and installed it, but 'openct-tool list' does not show it.
prtconf shows usb_mid driver attached to it. It does not sound like the right driver. What am I
missing?
 
Thanks,
Kandy
 

_______________________________________________
opensc-devel mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-devel
Reply | Threaded
Open this post in threaded view
|

Re: Axalto Egate (USB) Working on Solaris 10?

Andreas Jellinghaus-2
On Wednesday 31 August 2005 20:43, Palanisamy, Kandasamy (Kandasamy) wrote:
>     Does Axalto egate (Cryotoflex) USB smart card work on Solaris 10
> with OpenCT and OpenSC?

I don't know. I don't have a solaris box, so I can't test.

you could edit openct.conf and set debugging level to 6 or higher.
run opensc-control init and see what happends (check syslog messages).
if everything is ok then you should see an "ifdhandler" process being
started and that process should try to talk to the token.

Regards, Andreas
_______________________________________________
opensc-devel mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-devel
Reply | Threaded
Open this post in threaded view
|

RE: Axalto Egate (USB) Working on Solaris 10?

Palanisamy, Kandasamy (Kandasamy)
In reply to this post by Palanisamy, Kandasamy (Kandasamy)
Hello Andreas,

   It (opensc/openct) is now working, after I followed William
Wanders's suggestion that I remove the usb_mid driver and add
the ugen driver (see below for his message).

   Also, to get openct/opensc compiled on Solaris 10 using GNU
compiler, I had to remove '-pthread' from the configure scripts,
otherwise, I got a lot of undefined symbol errors from the linker.

Thanks,
Kandy

========================================================================
===

On Wed, Aug 31, 2005 at 12:43:10PM -0600, Palanisamy, Kandasamy
(Kandasamy) wrote:
> Hi,
>  
>     Does Axalto egate (Cryotoflex) USB smart card work on Solaris 10
> with OpenCT and OpenSC?
> I got OpenCT compiled on Solaris 10 and installed it, but 'openct-tool

> list' does not show it.
> prtconf shows usb_mid driver attached to it. It does not sound like
> the right driver. What am I missing?
On a default S10 or USB_DDK installation the usb_mid driver is used if
no more specific USB device driver is applicable. On my Solaris systems
I have changed the default configuration to use the Generic USB driver
(ugen) instead.

To achieve this I gave the following command as root:
# rem_drv usb_mid
# rem_drv ugnn
# add_drv -m '* 0666 bin bin' -i '"usb,device"' ugen

After reinserting the eGate usb plug the buittin smartcard should be
recognized like this:
# tail -f /var/adm/messages
Sep  1 14:50:25 enterprise usba: [ID 912658 kern.info] USB 1.10 device
(usb973,1) operating at low speed (USB 1.x) on USB 1.10 root hub:
device@1, ugen4 at bus address 3 Sep  1 14:50:25 enterprise usba: [ID
349649 kern.info]  SchlumbergerSema  Cryptoflex e-gate Sep  1 14:50:25
enterprise genunix: [ID 936769 kern.info] ugen4 is
/pci@1f,0/pci@5/usb@0/device@1 Sep  1 14:50:25 enterprise genunix: [ID
408114 kern.info] /pci@1f,0/pci@5/usb@0/device@1 (ugen4) online

Now it ought to be possible to list and check the device # openct-tool
list
  0 Schlumberger E-Gate
  1 CCID Compatible

# openct-tool atr
Detected Schlumberger E-Gate
Card present, status changed
ATR: 3b 95 18 40 ff 62 01 02 01 04

Hope this will help you.

Regards,

William Wanders.
 

-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Andreas
Jellinghaus
Sent: Thursday, September 01, 2005 1:48 PM
To: [hidden email]
Subject: Re: [opensc-devel] Axalto Egate (USB) Working on Solaris 10?

On Wednesday 31 August 2005 20:43, Palanisamy, Kandasamy (Kandasamy)
wrote:
>     Does Axalto egate (Cryotoflex) USB smart card work on Solaris 10
> with OpenCT and OpenSC?

I don't know. I don't have a solaris box, so I can't test.

you could edit openct.conf and set debugging level to 6 or higher.
run opensc-control init and see what happends (check syslog messages).
if everything is ok then you should see an "ifdhandler" process being
started and that process should try to talk to the token.

Regards, Andreas
_______________________________________________
opensc-devel mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-devel


_______________________________________________
opensc-devel mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-devel