Compile newest version of opensc, pcsc-lite and ccid

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Compile newest version of opensc, pcsc-lite and ccid

Josef Windorfer
Hi,

I have problems by compiling the newest source files from opensc
0.12-svn-r4623, pcsc-lite 1.6.2 and libccid 1.4.0.

The error comes when i install first pcsc-lite then libccid and at least
opensc.
The compilation of pcsc-lite and libccid finished fine, but when i
perform 'make' the error occur. (In the attachment is the terminal
output of 'make'.)

The strange thing is, when i have installed a older version of pcsc-lite
and ccid and replace it by the newest version, opensc works without an
error.

Greets
Josef



Am 15.08.2010 10:01, schrieb Martin Paljak:

> Hello,
>
> On Aug 3, 2010, at 11:05 PM, Andre Zepezauer wrote:
>> in the interests of the users of OpenSC, it would be fair to apply the
>> following patch.
> FYI: I gathered all opensc.conf entries [1] that can have security/intrusion related effects to the wiki page dealing with security considerations [2].
>
> The list can be incomplete as well as implications incorrect. As always it comes with no warranty and as is.
> YMMV. Feel free to update/correct it.
>
>> + # WE (THE OPENSC DEVELOPERS) ARE VERY AWARE OF THE FACT, THAT
>> + # THIS FEATURE IS INSECURE. NEVERTHELESS IT IS ENABLED BY DEFAULT,
>> + # BECAUSE WE DON'T CARE ABOUT YOUR (THE USERS) SECURITY NEEDS.
>
>
> Please describe your security needs so that they could be understood and addressed better.
>
> [1] http://www.opensc-project.org/opensc/wiki/SecurityConsiderations#Relevantopensc.confentries
> [2] http://www.opensc-project.org/opensc/wiki/SecurityConsiderations
>

_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc-project.org/mailman/listinfo/opensc-user
Reply | Threaded
Open this post in threaded view
|

Re: Compile newest version of opensc, pcsc-lite and ccid

Ludovic Rousseau
2010/8/15 Josef Windorfer <[hidden email]>:
> Hi,

Hello,

> I have problems by compiling the newest source files from opensc
> 0.12-svn-r4623, pcsc-lite 1.6.2 and libccid 1.4.0.

I can reproduce the problem.

> The error comes when i install first pcsc-lite then libccid and at least
> opensc.
> The compilation of pcsc-lite and libccid finished fine, but when i perform
> 'make' the error occur. (In the attachment is the terminal output of
> 'make'.)
>
> The strange thing is, when i have installed a older version of pcsc-lite and
> ccid and replace it by the newest version, opensc works without an error.

pcsc-lite 1.6.2 removed the definition of SCARD_READERSTATE_A.
Applications should use SCARD_READERSTATE instead.
I fixed OpenSC is revision 4626.

pcsc-lite 1.6.2 also removed the definition of LPSCARD_READERSTATE and
this is a mistake.
I fixed pcsc-lite in revision 5134.

I will release a new pcsc-lite 1.6.3 soon.

Thanks

--
 Dr. Ludovic Rousseau
_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc-project.org/mailman/listinfo/opensc-user
Reply | Threaded
Open this post in threaded view
|

Re: Compile newest version of opensc, pcsc-lite and ccid

Ludovic Rousseau
2010/8/15 Ludovic Rousseau <[hidden email]>:
> I will release a new pcsc-lite 1.6.3 soon.

pcsc-lite 1.6.3 is out now.

Bye

--
 Dr. Ludovic Rousseau
_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc-project.org/mailman/listinfo/opensc-user
Reply | Threaded
Open this post in threaded view
|

Re: Compile newest version of opensc, pcsc-lite and ccid

Josef Windorfer
Hi,

good news!

I can verify the bugfix.
I have installed opensc 0.12-svn-r4626, pcsc-lite 1.6.3 and libccid
1.4.0 and it works fine.

Bye
Josef

Am 15.08.2010 18:05, schrieb Ludovic Rousseau:
> 2010/8/15 Ludovic Rousseau<[hidden email]>:
>> I will release a new pcsc-lite 1.6.3 soon.
>
> pcsc-lite 1.6.3 is out now.
>
> Bye
>
_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc-project.org/mailman/listinfo/opensc-user
Reply | Threaded
Open this post in threaded view
|

Re: Compile newest version of opensc, pcsc-lite and ccid

Jean-Michel Pouré - GOOZE
On Sun, 2010-08-15 at 18:25 +0200, Josef Windorfer wrote:
> I have installed opensc 0.12-svn-r4626, pcsc-lite 1.6.3 and libccid
> 1.4.0 and it works fine.

By the way, it would be nice to have the latest versions in Debian SID.
People are getting confused with Debian experimental.

IMHO I would prefer pcsc-lite 1.6.3, libccid 1.4.0 and a recent OpenSC
release in Debian SID. This is always more stable and people will test
and adopt OpenSC. When there is a big bugfix, make release and push to
SID.

Kind regards,
--
                  Jean-Michel Pouré - Gooze - http://www.gooze.eu

_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc-project.org/mailman/listinfo/opensc-user

smime.p7s (8K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Compile newest version of opensc, pcsc-lite and ccid

Ludovic Rousseau
Le 16 août 2010 18:45, Jean-Michel Pouré - GOOZE <[hidden email]> a écrit :
> On Sun, 2010-08-15 at 18:25 +0200, Josef Windorfer wrote:
>> I have installed opensc 0.12-svn-r4626, pcsc-lite 1.6.3 and libccid
>> 1.4.0 and it works fine.
>
> By the way, it would be nice to have the latest versions in Debian SID.
> People are getting confused with Debian experimental.

Debian testing is now frozen [1]. So it is not a good time to upload
to sid/unstable except to fix release critical bugs.

> IMHO I would prefer pcsc-lite 1.6.3, libccid 1.4.0 and a recent OpenSC
> release in Debian SID. This is always more stable and people will test
> and adopt OpenSC. When there is a big bugfix, make release and push to
> SID.

Just wait a few weeks/months for the next Debian to be released.

Bye

[1] http://www.debian.org/News/2010/20100806

--
 Dr. Ludovic Rousseau
_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc-project.org/mailman/listinfo/opensc-user
Reply | Threaded
Open this post in threaded view
|

OpenSC Windows Installer

Josef Windorfer
Hi,

i tried to install OpenSC-0.12.0.exe in Windows XP SP3 from here:
http://www.opensc-project.org/opensc/wiki/WindowsInstaller.
Used hardware: ePass PKI Token
(http://www.gooze.eu/feitian-epass-pki-token)

Is this version a real 0.12 svn version?
opensc-tool -i says 0.11.13.

Does this Installer work proberly?
I can dump (pkcs15-tool -D) the content of the Token, but i can't
generate a new key pair. See Screenshot.

Kind Regards
Josef


P.S. Sorry for the picture. It's impossible (for me) to copy from the
terminal




_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc-project.org/mailman/listinfo/opensc-user

Screenshot.jpg (255K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: OpenSC Windows Installer

Martin Paljak-2
Hello,
On Aug 18, 2010, at 11:12 PM, Josef Windorfer wrote:
> i tried to install OpenSC-0.12.0.exe in Windows XP SP3 from here: http://www.opensc-project.org/opensc/wiki/WindowsInstaller.
> Used hardware: ePass PKI Token
> (http://www.gooze.eu/feitian-epass-pki-token)

Please try again with a installer from the same URL.
The problem (missing profile directory in opensc.conf) was fixed in r4652[1] and the corresponding new installer is available from [2].


[1] http://www.opensc-project.org/opensc/changeset/4652
[2] http://www.opensc-project.org/files/contrib/OpenSC-0.12.0.exe
--
Martin Paljak
@martinpaljak.net
+3725156495

_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc-project.org/mailman/listinfo/opensc-user
Reply | Threaded
Open this post in threaded view
|

Re: OpenSC Windows Installer

Josef Windorfer
Hi Martin,

thank you. It works fine!

Kind Regards
Josef


Am 25.08.2010 15:39, schrieb Martin Paljak:

> Hello,
> On Aug 18, 2010, at 11:12 PM, Josef Windorfer wrote:
>> i tried to install OpenSC-0.12.0.exe in Windows XP SP3 from here: http://www.opensc-project.org/opensc/wiki/WindowsInstaller.
>> Used hardware: ePass PKI Token
>> (http://www.gooze.eu/feitian-epass-pki-token)
>
> Please try again with a installer from the same URL.
> The problem (missing profile directory in opensc.conf) was fixed in r4652[1] and the corresponding new installer is available from [2].
>
>
> [1] http://www.opensc-project.org/opensc/changeset/4652
> [2] http://www.opensc-project.org/files/contrib/OpenSC-0.12.0.exe
_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc-project.org/mailman/listinfo/opensc-user