Further problems with openSC and aladdin eToken

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Further problems with openSC and aladdin eToken

Nick Johnson-11
I've tried reinitializing my eToken with opensc and generating a key -
all fine. The problems come when I try and generate a self-signed cert
from that key under windows:
---
OpenSSL> engine dynamic -pre SO_PATH:engine_pkcs11 -pre ID:pkcs11 -pre
LIST_ADD:
1 -pre LOAD
(dynamic) Dynamic engine loading support
[Success]: SO_PATH:engine_pkcs11
[Success]: ID:pkcs11
[Success]: LIST_ADD:1
[Success]: LOAD
Loaded: (pkcs11) pkcs11 engine
OpenSSL> req -engine pkcs11 -new -key id_45 -keyform engine -x509 -out
mycert.pe
m -config "c:\program files\smart card bundle\openssl.cnf" -subj
"/CN=Nick Johns
on/emailAddress=[hidden email]"
unable to load module (null)
can't use that engine
2124:error:80001401:Vendor defined:PKCS11_CTX_load:Unable to load
PKCS#11 module
:p11_load.c:57:
2124:error:260B806D:engine routines:ENGINE_TABLE_REGISTER:init
failed:.\crypto\e
ngine\eng_table.c:161:
no engine specified
unable to load Private Key
error in req
---

Anyone know why this is happening, and how I can fix it?

Thanks,

Nick Johnson

_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc-project.org/mailman/listinfo/opensc-user
Reply | Threaded
Open this post in threaded view
|

Re: Further problems with openSC and aladdin eToken

Andreas Jellinghaus-2
you did not specifiy the pkcs#11 module to load.
take a look at
        http://www.opensc-project.org/engine_pkcs11/wiki/QuickStart

(oops, the scb side had the old/wrong commands, will fix that)

Andreas
_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc-project.org/mailman/listinfo/opensc-user
Reply | Threaded
Open this post in threaded view
|

Re: Further problems with openSC and aladdin eToken

Nick Johnson-11
Andreas Jellinghaus wrote:

>you did not specifiy the pkcs#11 module to load.
>take a look at
> http://www.opensc-project.org/engine_pkcs11/wiki/QuickStart
>
>(oops, the scb side had the old/wrong commands, will fix that)
>  
>
I was working off the scb wiki, which would explain it.
However, now when I try:
OpenSSL> engine -t dynamic -pre SO_PATH:engine_pkcs11 -pre ID:pkcs11
-pre LIST_ADD:1 -pre LOAD -pre MODULE_PATH:opensc-pkcs11

I get:
(dynamic) Dynamic engine loading support
[Success]: SO_PATH:engine_pkcs11
[Success]: ID:pkcs11
[Success]: LIST_ADD:1
[Success]: LOAD
[Success]: MODULE_PATH:opensc-pkcs11
Loaded: (pkcs11) pkcs11 engine

And then openssl crashes with a windows error dialog.
The details have:
AppName: openssl.exe
AppVer: 0.0.0.0
ModName: unknown
ModVer: 0.0.0.0
Offset 1140003d

-Nick Johnson
_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc-project.org/mailman/listinfo/opensc-user