Loading PKCS#11 in Thunderbird under Windows

classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|

Loading PKCS#11 in Thunderbird under Windows

dgambin
Hello,

I have successfully loaded PKCS#11 module in Mozilla Firefox, but I
can't do the same in Thunderbird. The "Load PKCS#11 Device" dialog keeps
displaying but nothing happens. Task Manager report "...non
responding..."

Did anyone experience something similar?

regards, dejan
_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user
Reply | Threaded
Open this post in threaded view
|

Re: Loading PKCS#11 in Thunderbird under Windows

Jan Schermer
Try alt+tabbing through windows, this happened to me and there was a PIN
request hidden in the background blocking the other windows...

Jan

Gambin Dejan wrote:

>Hello,
>
>I have successfully loaded PKCS#11 module in Mozilla Firefox, but I
>can't do the same in Thunderbird. The "Load PKCS#11 Device" dialog keeps
>displaying but nothing happens. Task Manager report "...non
>responding..."
>
>Did anyone experience something similar?
>
>regards, dejan
>_______________________________________________
>opensc-user mailing list
>[hidden email]
>http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user
>  
>

_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user

smime.p7s (3K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

RE: Loading PKCS#11 in Thunderbird under Windows

dgambin
In reply to this post by dgambin
No, there is no pin dialog in the background...but it must be something
really stupid...I am doing it for the first time so...

dejan

-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Jan Schermer
Sent: Thursday, September 22, 2005 10:20 AM
To: [hidden email]
Subject: Re: [opensc-user] Loading PKCS#11 in Thunderbird under Windows


Try alt+tabbing through windows, this happened to me and there was a PIN

request hidden in the background blocking the other windows...

Jan

Gambin Dejan wrote:

>Hello,
>
>I have successfully loaded PKCS#11 module in Mozilla Firefox, but I
>can't do the same in Thunderbird. The "Load PKCS#11 Device" dialog
>keeps displaying but nothing happens. Task Manager report "...non
>responding..."
>
>Did anyone experience something similar?
>
>regards, dejan
>_______________________________________________
>opensc-user mailing list
>[hidden email]
>http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user
>  
>
_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user
Reply | Threaded
Open this post in threaded view
|

RE: Loading PKCS#11 in Thunderbird under Windows

Michal Prochazka
Hello,

try to close all Firefox and try it again.

Don't forget to change "lock_login" to false in opensc.conf, otherwise you
cannot use smartcard in Thunderbird and Firefox together.

Michal

-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Gambin Dejan
Sent: Thursday, September 22, 2005 10:25 AM
To: Jan Schermer
Cc: [hidden email]
Subject: RE: [opensc-user] Loading PKCS#11 in Thunderbird under Windows

No, there is no pin dialog in the background...but it must be something
really stupid...I am doing it for the first time so...

dejan

-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Jan Schermer
Sent: Thursday, September 22, 2005 10:20 AM
To: [hidden email]
Subject: Re: [opensc-user] Loading PKCS#11 in Thunderbird under Windows


Try alt+tabbing through windows, this happened to me and there was a PIN

request hidden in the background blocking the other windows...

Jan

Gambin Dejan wrote:

>Hello,
>
>I have successfully loaded PKCS#11 module in Mozilla Firefox, but I
>can't do the same in Thunderbird. The "Load PKCS#11 Device" dialog
>keeps displaying but nothing happens. Task Manager report "...non
>responding..."
>
>Did anyone experience something similar?
>
>regards, dejan
>_______________________________________________
>opensc-user mailing list
>[hidden email]
>http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user 
>  
>
_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user 


_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user
Reply | Threaded
Open this post in threaded view
|

RE: Loading PKCS#11 in Thunderbird under Windows

dgambin
In reply to this post by dgambin
Thanks Jan,

Well it shouldn't been locked by any application because I have loaded
the module in Firefox jus berfore. I have closed all Firefox windows but
the error remained...after removing and inserting the card again (well I
removed/inserted the pcmcia reader too), it works...some locking
obviously happened...

regards, dejan

-----Original Message-----
From: Jan Schermer [mailto:[hidden email]]
Sent: Thursday, September 22, 2005 10:32 AM
To: Gambin Dejan
Subject: Re: [opensc-user] Loading PKCS#11 in Thunderbird under Windows


I don't know much about windows OpenSC(?), isn't the token just locked
by some other app?

Gambin Dejan wrote:

>No, there is no pin dialog in the background...but it must be something

>really stupid...I am doing it for the first time so...
>
>dejan
>
>-----Original Message-----
>From: [hidden email]
>[mailto:[hidden email]] On Behalf Of Jan Schermer
>Sent: Thursday, September 22, 2005 10:20 AM
>To: [hidden email]
>Subject: Re: [opensc-user] Loading PKCS#11 in Thunderbird under Windows
>
>
>Try alt+tabbing through windows, this happened to me and there was a
>PIN
>
>request hidden in the background blocking the other windows...
>
>Jan
>
>Gambin Dejan wrote:
>
>  
>
>>Hello,
>>
>>I have successfully loaded PKCS#11 module in Mozilla Firefox, but I
>>can't do the same in Thunderbird. The "Load PKCS#11 Device" dialog
>>keeps displaying but nothing happens. Task Manager report "...non
>>responding..."
>>
>>Did anyone experience something similar?
>>
>>regards, dejan _______________________________________________
>>opensc-user mailing list
>>[hidden email]
>>http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user
>>
>>
>>    
>>
_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user
Reply | Threaded
Open this post in threaded view
|

RE: Loading PKCS#11 in Thunderbird under Windows

dgambin
In reply to this post by dgambin
Thanks for the info...

-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Michal
Prochazka
Sent: Thursday, September 22, 2005 10:31 AM
To: [hidden email]
Subject: RE: [opensc-user] Loading PKCS#11 in Thunderbird under Windows


Hello,

try to close all Firefox and try it again.

Don't forget to change "lock_login" to false in opensc.conf, otherwise
you cannot use smartcard in Thunderbird and Firefox together.

Michal

-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Gambin Dejan
Sent: Thursday, September 22, 2005 10:25 AM
To: Jan Schermer
Cc: [hidden email]
Subject: RE: [opensc-user] Loading PKCS#11 in Thunderbird under Windows

No, there is no pin dialog in the background...but it must be something
really stupid...I am doing it for the first time so...

dejan

-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Jan Schermer
Sent: Thursday, September 22, 2005 10:20 AM
To: [hidden email]
Subject: Re: [opensc-user] Loading PKCS#11 in Thunderbird under Windows


Try alt+tabbing through windows, this happened to me and there was a PIN


request hidden in the background blocking the other windows...

Jan

Gambin Dejan wrote:

>Hello,
>
>I have successfully loaded PKCS#11 module in Mozilla Firefox, but I
>can't do the same in Thunderbird. The "Load PKCS#11 Device" dialog
>keeps displaying but nothing happens. Task Manager report "...non
>responding..."
>
>Did anyone experience something similar?
>
>regards, dejan
>_______________________________________________
>opensc-user mailing list
>[hidden email]
>http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user 
>  
>
_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user 


_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user
_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user
Reply | Threaded
Open this post in threaded view
|

Re: Loading PKCS#11 in Thunderbird under Windows

Andreas Jellinghaus-2
In reply to this post by dgambin
On Thursday 22 September 2005 10:17, Gambin Dejan wrote:
> Hello,
>
> I have successfully loaded PKCS#11 module in Mozilla Firefox, but I
> can't do the same in Thunderbird. The "Load PKCS#11 Device" dialog keeps
> displaying but nothing happens. Task Manager report "...non
> responding..."

was firefox still open?

maybe it is this: if I remember correctly,
you can't run both at the same time.
both try to get exclusive ownership of the token.

so once you start the second one, it will wait
till it has full access to the token.

if I'm guessing right, closing firefox should make
thunderbird work.

There is an option in opensc.conf to disable
locking. that could cause a security problem,
and might end in problems, if two applications
try to use the token exactly the same time.
but in general it should improve your sitation.

please let me know if I guessed right, so I
can update the documentation with your results.

good luck!

Andreas
_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user
Reply | Threaded
Open this post in threaded view
|

RE: Loading PKCS#11 in Thunderbird under Windows

dgambin
In reply to this post by dgambin
Andreas,

Thanks for the info. As I have already told, I have successfully loaded
the token after reinserting the card (but I have also reinserted the
pcmcia reader). Before that, if I remember correctly, I have tried to
close all the firefox windows and I still couldn't load the module in
Thunderbird. If you really need to test this behaviour, I shall do it
again...

regards, dejan

-----Original Message-----
From: Andreas Jellinghaus [mailto:[hidden email]]
Sent: Thursday, September 22, 2005 9:16 PM
To: [hidden email]
Cc: Gambin Dejan
Subject: Re: [opensc-user] Loading PKCS#11 in Thunderbird under Windows


On Thursday 22 September 2005 10:17, Gambin Dejan wrote:
> Hello,
>
> I have successfully loaded PKCS#11 module in Mozilla Firefox, but I
> can't do the same in Thunderbird. The "Load PKCS#11 Device" dialog
> keeps displaying but nothing happens. Task Manager report "...non
> responding..."

was firefox still open?

maybe it is this: if I remember correctly,
you can't run both at the same time.
both try to get exclusive ownership of the token.

so once you start the second one, it will wait
till it has full access to the token.

if I'm guessing right, closing firefox should make
thunderbird work.

There is an option in opensc.conf to disable
locking. that could cause a security problem,
and might end in problems, if two applications
try to use the token exactly the same time.
but in general it should improve your sitation.

please let me know if I guessed right, so I
can update the documentation with your results.

good luck!

Andreas
_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user
Reply | Threaded
Open this post in threaded view
|

Re: Loading PKCS#11 in Thunderbird under Windows

Andreas Jellinghaus-2
Hi Gambin,

it would help if you could reproduce the bug
so we can find and fix it.

Which version of OpenSC did you try? Did you compile
it yourself or did you use the Smart card bundle?
If so which version / could you try the 0.5-pre1e
version at
http://www.opensc.org/scb/file/trunk/scb-0.5-pre1e.exe

and see if it has the same problems?

Regards, Andreas
_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user
Reply | Threaded
Open this post in threaded view
|

RE: Loading PKCS#11 in Thunderbird under Windows

dgambin
Hi Andreas,

I am using opensc-0.9.6 and I havce compiled it by myself using Visual
Studio 6. To be honest, I can't reproduce the bug anymore. After setting
lock_login to false everything went OK. Last half an hour I am trying to
reproduce the bug by setting lock_login to true again, but nothing goes
wrong....I have tried to reinsert the card/reader but nothing
happens...I will try again

By the way, I am trying to generate the keypair on the card. I have been
following the Stef procedure, but the point is I am using JCOP cards
that have their own initialization routines (written by Chaskiel
Grundman) so I can't initialize them with onepin option (or I don't know
how..)...but I can't generate the keypair with pkcs11-tool neither (with
or without the --moz-cert option), I get CKR_GENERAL_ERROR....any
suggestion?

regards, dejan

-----Original Message-----
From: Andreas Jellinghaus [mailto:[hidden email]]
Sent: Friday, September 23, 2005 9:42 AM
To: [hidden email]
Cc: Gambin Dejan
Subject: Re: [opensc-user] Loading PKCS#11 in Thunderbird under Windows


Hi Gambin,

it would help if you could reproduce the bug
so we can find and fix it.

Which version of OpenSC did you try? Did you compile
it yourself or did you use the Smart card bundle?
If so which version / could you try the 0.5-pre1e
version at http://www.opensc.org/scb/file/trunk/scb-0.5-pre1e.exe

and see if it has the same problems?

Regards, Andreas

_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user
Reply | Threaded
Open this post in threaded view
|

Re: Loading PKCS#11 in Thunderbird under Windows

Andreas Jellinghaus-2
On Sunday 25 September 2005 23:25, Dejan Gambin wrote:
> By the way, I am trying to generate the keypair on the card. I have been
> following the Stef procedure, but the point is I am using JCOP cards
> that have their own initialization routines (written by Chaskiel
> Grundman) so I can't initialize them with onepin option (or I don't know
> how..)...but I can't generate the keypair with pkcs11-tool neither (with
> or without the --moz-cert option), I get CKR_GENERAL_ERROR....any

if pkcs15-init doesn't work, no other option will.

can you use pkcs15-init without onepin option?
sure, that way you can't create keys in mozilla,
but need to create them on card.

also note: only some jcop cards are supported, see the wiki page
for details.

I'm don't know jcop and don't have such a card. maybe chaskiel can help
you?

Regards, Andreas
_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user
Reply | Threaded
Open this post in threaded view
|

RE: Loading PKCS#11 in Thunderbird under Windows

dgambin
In reply to this post by dgambin
Thanks Andreas,

As I told you, pkcs15-init -C and -E options do not work with jcop, and
this is because I am using the separate initialization routines that
Chaskiel has created. That is the reason I can't create "onepin profile"
pkcs15 card....but even pkcs15-init -G doesn't work and now I am
expecting why. I am in contact with Chaskiel and sure he knows best the
JCOP stuff.

Thanks anyway

regards, dejan

-----Original Message-----
From: Andreas Jellinghaus [mailto:[hidden email]]
Sent: Monday, September 26, 2005 9:39 AM
To: [hidden email]
Cc: Gambin Dejan
Subject: Re: [opensc-user] Loading PKCS#11 in Thunderbird under Windows


On Sunday 25 September 2005 23:25, Dejan Gambin wrote:
> By the way, I am trying to generate the keypair on the card. I have
> been following the Stef procedure, but the point is I am using JCOP
> cards that have their own initialization routines (written by Chaskiel
> Grundman) so I can't initialize them with onepin option (or I don't
> know how..)...but I can't generate the keypair with pkcs11-tool
> neither (with or without the --moz-cert option), I get
> CKR_GENERAL_ERROR....any

if pkcs15-init doesn't work, no other option will.

can you use pkcs15-init without onepin option?
sure, that way you can't create keys in mozilla,
but need to create them on card.

also note: only some jcop cards are supported, see the wiki page for
details.

I'm don't know jcop and don't have such a card. maybe chaskiel can help
you?

Regards, Andreas
_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user