OpenSC 0.9.6 and Cryptoflex 32K

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

OpenSC 0.9.6 and Cryptoflex 32K

ToDD-2
Hi!

I'm trying to use OpenSC 0.9.6 under Windows XP, self compiled.

Maybe I should use scb? However previous version of OpenSC worked fine for me.

apdu_masquerade = none

Regards,
ToDD

_______________________________________________
opensc-devel mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-devel
Reply | Threaded
Open this post in threaded view
|

Re: OpenSC 0.9.6 and Cryptoflex 32K

Andreas Jellinghaus-2
Hi ToDD,

I had to change apdu_masquerade to case4as3 to get Cryptoflex 32k
cards to work (in egate token adapter). I'm not sure if this is a
card issue or a reader driver issue.

Also one small change we did was add a msleep() call to card-flex.c
You could try to remove that line and see if it helps. I needed to
add it for that cryptoflex 32k/ egate combination, and my
normal cryptoflex cards on linux and in other reader still work,
so it shouldn't hurt anyone.

Please let us know if one of these changes solves your problems.

Regards, Andreas
_______________________________________________
opensc-devel mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-devel