OpenSC binaries for MacOS X 10.6.2?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

OpenSC binaries for MacOS X 10.6.2?

Peter Pentchev
Hi,

First of all, thanks for maintaining OpenSC!

Is there anywhere I can download a x86_64 binary installation for
MacOS X 10.6.2?  In the files/contrib/ directory there is OpenSC-10.6.dmg,
but it seems to require MacOS X 10.6.4, and, for various reasons,
a customer of ours needs to run at least a test setup on 10.6.2.
So is there any chance anybody is keeping old binaries around, and
has a fat build with the 64-bit x86_64 architecture included? :)

Thanks in advance, and keep up the good work!

G'luck,
Peter

--
Peter Pentchev [hidden email]    [hidden email]    [hidden email]
PGP key: http://people.FreeBSD.org/~roam/roam.key.asc
Key fingerprint FDBA FD79 C26F 3C51 C95E  DF9E ED18 B68D 1619 4553
You have, of course, just begun reading the sentence that you have just finished reading.

_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc-project.org/mailman/listinfo/opensc-user

signature.asc (853 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: OpenSC binaries for MacOS X 10.6.2?

Martin Paljak-2
Hello,
On Wed, Oct 13, 2010 at 14:18, Peter Pentchev <[hidden email]> wrote:
> Is there anywhere I can download a x86_64 binary installation for
> MacOS X 10.6.2?  In the files/contrib/ directory there is OpenSC-10.6.dmg,
> but it seems to require MacOS X 10.6.4, and, for various reasons,
> a customer of ours needs to run at least a test setup on 10.6.2.
> So is there any chance anybody is keeping old binaries around, and
> has a fat build with the 64-bit x86_64 architecture included? :)

As a general rule, requiring an up to date (with security updates)
operating system is a right choice. Also, because releases require
testing, it is easiest to test just a single version of an OS.

Anyway, the limit to require 10.6.4 is hopefully artificial and can be
lowered by editing a file [1] in your SVN checkout before creating the
installer [2].

Also, editing the InstallationCheck in the DMG to remove the 10.6.4
requirement is possible, or using a tool like Pacifist.

If you need a 10.6.2 build for your *customer*, you can also paypal me
€5.50 and I'll build you one ;)

[1] http://www.opensc-project.org/opensc/browser/trunk/MacOSX/10.6/scripts/InstallationCheck#L12
[2] http://www.opensc-project.org/opensc/wiki/MacInstaller#Buildingtheinstaller
_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc-project.org/mailman/listinfo/opensc-user