OpenSC now supports the use of OpenSSL-1.1.0 - Major API changes

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

OpenSC now supports the use of OpenSSL-1.1.0 - Major API changes

Douglas E Engert
The OpenSSL-1.1.0 API now used within OpenSC. OpenSC developers are in encouraged to read

  https://github.com/OpenSC/OpenSC/pull/861

src/libopensc/sc-ossl-compat.h uses defines, macros and inline code for backward compatibility with older versions of OpenSSL. It only implements backward compatibility for functions currently used by
OpenSC and may need additional changes.

PR 861 changed a lot of code and only partially tested. Please test the https://github.com/OpenSC/OpenSC master branch with any of your devices or proposed changes. You can test with whatever OpenSSL
version you need. But you may need to change your code to use the OPenSSL-1.1.0 API.

https://github.com/OpenSC/OpenSC/pull/884 is the first bug found with the code. It showed up on MacOS.

--

  Douglas E. Engert  <[hidden email]>
 


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Opensc-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/opensc-devel