Re: pkcs15-init on MacOSX Tiger

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: pkcs15-init on MacOSX Tiger

Stef Hoeben-2
Hi,

same results as Jean-Piere over here; and I first had to install fink's
pkg-config
(but that's no realy a problem as we already need fink's autotools).

So the problem is we have to tell pkg-config where to find the pkgconfig
dir, right?

Any solutions for this, or do we just have to accept and document it (just
as we have to do for a Windows build now scdl has been replaced by ltdl)?

In the latter case, I'd propose to put a warning in the configure script
if possible:
  if (mac && !openssl) print "Install fink's pkg-config and set the
PKG_CONF_PATH"
or so...

Stef

JP Szikora wrote:

> Andreas Jellinghaus wrote:
>
>> Hi,
>>
>> do you have pkg-config on your system?
>>  
>>
> Hi Andreas,
>
> Welcome to Darwin!
> m-75-4-5616-30:~ jps$ pkg-config
> Must specify package names on the command line
>
>> does "pkg-config openssl" find openssl?
>>  
>>
> No.
>
>> do you have a openssl.pc file on your system?
>>  
>>
> m-75-4-5616-30:~ jps$ locate openssl.pc
> /usr/lib/pkgconfig/openssl.pc
>
>> if pkg-config does not find it, but there is one,
>> can you try with
>> export PKG_CONFIG_PATH=/usr/lib/pkgconfig
>>  
>>
> OK, I add this in my .bash_profile. And after relogging, I get this at
> the end of the ./configure.
>
> Host:                powerpc-apple-darwin8.2.0
> Compiler:            gcc
> Compiler flags:      -Wall -fno-strict-aliasing -g -O2 -no-cpp-precomp
> Preprocessor flags:  -I${top_builddir}/src/include
> Linker flags:
> Libraries:             -Wl,-framework,CoreFoundation -lz
>
> OpenSSL support:          yes
> PC/SC support:            yes
> OpenCT support:           no
> Assuan support:           no
>
> And after the make the pkcs15-init was there.
>
> This will probably a general problem with the Macs, I'm afraid...
>
> Thanks for your help.
>
> Regards,
>
> Jean-Pierre
>
>> (or whatever the directory with that file is)?
>>
>> alternative:
>> export OPENSSL_CFLAGS=""
>> export OPENSSL_LIBS="-lcrypto"
>>
>> should also do the trick.
>> (or add -I/path/to/include and -L/path/to/lib if needed).
>>
>> Regards, Andreas
>>  
>>
>

_______________________________________________
opensc-devel mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-devel
Reply | Threaded
Open this post in threaded view
|

SVN2622 can not be compiled on Windows

JP Szikora
Hi Andreas,

I can not compile anymore opensc on windows after the modifications you
made in SVN2522.

The first errors are:
getopt.c(73) : fatal error C1083: Cannot open include file: 'gettext.h':
No such
 file or directory getopt1.c
getopt_int.h(1) : fatal error C1083: Cannot open include file:
'posix/getopt_int
.h': No such file or directory

Regards,

Jean-Pierre

--
Dr Jean-Pierre Szikora                   e-mail: [hidden email]
                                            tel: 32-2-764.75.00
74, av. Hippocrate - UCL 7459               fax: 32-2-764.65.65
1200 Brussels - Belgium                 PGP key: 0x6FCD7405

_______________________________________________
opensc-devel mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-devel
Reply | Threaded
Open this post in threaded view
|

Re: Re: pkcs15-init on MacOSX Tiger

Andreas Jellinghaus-2
In reply to this post by Stef Hoeben-2
If we can fix it easilty, I would prefer that,
if not we need to role back to the old version.

unfortunatly my mac os X tiger does seem to have
getopt, so I can't test, I have no system
without getopt.

it shouldn't be to hard to fix it, maybe edit a
few include commands and add a -I... to INCLUDES
in the makefile. (or we can build a library
and include it that way, less trouble with includes).
but without a system fo testing it is hard for me
to try that.

Andreas
_______________________________________________
opensc-devel mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-devel
Reply | Threaded
Open this post in threaded view
|

Re: SVN2622 can not be compiled on Windows

Andreas Jellinghaus-2
In reply to this post by JP Szikora
Hi Jean-Pierre,

could you try current svn?
I replaced the getopt code frm gnu/glibc with my_getopt (bsd license)
and it works fine for me on windows.

I haven't tried mac os X so far, and it would be very helpful
if you could test all plattforms you have :)

that problem is the biggest stopper for beta2...

Thanks for your help!

Regards, Andreas
_______________________________________________
opensc-devel mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-devel