[Snapshot] - Help - Win32 0.9.6 Snapshot

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

[Snapshot] - Help - Win32 0.9.6 Snapshot

Pier Paolo Bortone
Hi all,
 
I'm testing the OpenSC framework with the InfoCamere card (STARCOS SPK 2.3) 
on Win32 environment. But I'm using the old snapshot 0.9.4 for win32 and I'm encountering
several knew BUGS.
 
At this time I cannot build source code for various reasons, but I need 0.9.6 version
for win32.
 
Is there someone that have created the win32 snapshot for 0.9.6 version?
 
Thanks in advance.
 
Pier Paolo.
 
 
 

_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user
Reply | Threaded
Open this post in threaded view
|

Re: [Snapshot] - Help - Win32 0.9.6 Snapshot

Andreas Jellinghaus-2
Hi Pier,

opensc 0.9.6 compiles fine for me on windows.

Also we have a binary package that contains a pre-
compiled version, maybe that helps? it is called
"smart card bundle" and available at
http://www.opensc.org/scb/

(and if you look at "browse source" and
then "trunk" you will also find a preview
of the next version 0.5 :)

Feedback is very welcome!

Regards, Andreas
_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user
Reply | Threaded
Open this post in threaded view
|

R: [Snapshot] - Help - Win32 0.9.6 Snapshot

Pier Paolo Bortone
In reply to this post by Pier Paolo Bortone
Hi Andreas,
thanks for your answer.

Now I cannot launch build on windows, I will do it in the next future.

I tried to install scb (scb-0.5-pre1e.exe) but I got the same problem.

For example, if I execute command: pkcs11-tool -l -t
this is the output from opensc-errors.log:
File not found
card-starcos.c:317:starcos_select_fid: returning with: File not found
card.c:759:sc_select_file: returning with: File not found
X.509 certificate not found
Conditions of use not satisfied
card-starcos.c:1152:starcos_set_security_env: returning with: Not allowed
sec.c:67:sc_set_security_env: returning with: Not allowed
pkcs15-sec.c:312:sc_pkcs15_compute_signature: sc_set_security_env() failed: Not allowed

I think that the malfunctioning is due to this version of opensc,
looking the log file seems that the version is 0.9.4. Is it true?

Doesn't exist a version of scb with opensc 0.9.6?

I can upload the opensc-debug.log if it is necessary.

The card I'm trying to read is
InfoCamere 1202 series card (with STARCOS SPK 2.3).

Thanks in advance for the support.

Pier Paolo.


-----Messaggio originale-----
Da: Andreas Jellinghaus [mailto:[hidden email]]
Inviato: venerdì 30 settembre 2005 20.12
A: [hidden email]
Cc: Pier Paolo Bortone
Oggetto: Re: [opensc-user] [Snapshot] - Help - Win32 0.9.6 Snapshot

Hi Pier,

opensc 0.9.6 compiles fine for me on windows.

Also we have a binary package that contains a pre- compiled version, maybe that helps? it is called "smart card bundle" and available at http://www.opensc.org/scb/

(and if you look at "browse source" and
then "trunk" you will also find a preview of the next version 0.5 :)

Feedback is very welcome!

Regards, Andreas

_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user
Reply | Threaded
Open this post in threaded view
|

Re: R: [Snapshot] - Help - Win32 0.9.6 Snapshot

Andreas Jellinghaus-2
Hi Pier,

> I tried to install scb (scb-0.5-pre1e.exe) but I got the same problem.

sorry to hear that.

> For example, if I execute command: pkcs11-tool -l -t
> this is the output from opensc-errors.log:
> File not found
> card-starcos.c:317:starcos_select_fid: returning with: File not found
> card.c:759:sc_select_file: returning with: File not found
> X.509 certificate not found
> Conditions of use not satisfied
> card-starcos.c:1152:starcos_set_security_env: returning with: Not allowed
> sec.c:67:sc_set_security_env: returning with: Not allowed
> pkcs15-sec.c:312:sc_pkcs15_compute_signature: sc_set_security_env() failed:
Not allowed


hmm. I'm no expert on starcos etc., so I hope someone else can comment on
that. But I guess they need more details. (i.e. which file was not found
and so on). please increase debugging in the opensc config file.

> I think that the malfunctioning is due to this version of opensc,
> looking the log file seems that the version is 0.9.4. Is it true?
>
> Doesn't exist a version of scb with opensc 0.9.6?

scb 0.4.0 is opensc 0.9.6 and 0.5.0 will use opensc 0.10.0.

Andreas
_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user
Reply | Threaded
Open this post in threaded view
|

R: R: [Snapshot] - Help - Win32 0.9.6 Snapshot

Pier Paolo Bortone
In reply to this post by Pier Paolo Bortone
Hi Andreas,
I posted another message with detail of my card problem.

I want to tell you I succesfully installed SCB modifying somethings:
in file opensc.conf I changed
        profile_dir = PKGDATADIR;
to
        profile_dir = "C:\Programmi\Smart Card Bundle";

Thanks.

Pier Paolo.
   

-----Messaggio originale-----
Da: [hidden email] [mailto:[hidden email]] Per conto di Andreas Jellinghaus
Inviato: lunedì 3 ottobre 2005 23.26
Cc: [hidden email]
Oggetto: Re: R: [opensc-user] [Snapshot] - Help - Win32 0.9.6 Snapshot

Hi Pier,

> I tried to install scb (scb-0.5-pre1e.exe) but I got the same problem.

sorry to hear that.

> For example, if I execute command: pkcs11-tool -l -t this is the
> output from opensc-errors.log:
> File not found
> card-starcos.c:317:starcos_select_fid: returning with: File not found
> card.c:759:sc_select_file: returning with: File not found
> X.509 certificate not found
> Conditions of use not satisfied
> card-starcos.c:1152:starcos_set_security_env: returning with: Not
> allowed
> sec.c:67:sc_set_security_env: returning with: Not allowed
> pkcs15-sec.c:312:sc_pkcs15_compute_signature: sc_set_security_env() failed:
Not allowed


hmm. I'm no expert on starcos etc., so I hope someone else can comment on that. But I guess they need more details. (i.e. which file was not found and so on). please increase debugging in the opensc config file.

> I think that the malfunctioning is due to this version of opensc,
> looking the log file seems that the version is 0.9.4. Is it true?
>
> Doesn't exist a version of scb with opensc 0.9.6?

scb 0.4.0 is opensc 0.9.6 and 0.5.0 will use opensc 0.10.0.

Andreas
_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user

_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user
Reply | Threaded
Open this post in threaded view
|

Re: R: R: [Snapshot] - Help - Win32 0.9.6 Snapshot

Andreas Jellinghaus-2
On Tuesday 04 October 2005 19:20, Pier Paolo Bortone wrote:
> I want to tell you I succesfully installed SCB modifying somethings:
> in file opensc.conf I changed
> profile_dir = PKGDATADIR;
> to
> profile_dir = "C:\Programmi\Smart Card Bundle";

scb 0.5-pre1e should do that itself, the last step is
"view editconf.exe" (need to fix that description)
which runs a program to edit the opensc.conf file
and change the profile_dir entry.

maybe you unchecked that box?
(guess I should reconfigure the installer,
so it is alway run without even asking?)

Andreas
_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user
Reply | Threaded
Open this post in threaded view
|

R: R: R: [Snapshot] - Help - Win32 0.9.6 Snapshot

Pier Paolo Bortone
In reply to this post by Pier Paolo Bortone
Re: R: R: [opensc-user] [Snapshot] - Help - Win32 0.9.6 Snapshot
Hi Andreas,
yes I uncheked that box.
 
I'm agree with you on reconfiguration of the installer.
 
Thanks.
Pier Paolo
 
 
On Tuesday 04 October 2005 19:20, Pier Paolo Bortone wrote:
> I want to tell you I succesfully installed SCB modifying somethings:
> in file opensc.conf I changed
>       profile_dir = PKGDATADIR;
> to
>       profile_dir = "C:\Programmi\Smart Card Bundle";

scb 0.5-pre1e should do that itself, the last step is
"view editconf.exe" (need to fix that description)
which runs a program to edit the opensc.conf file
and change the profile_dir entry.

maybe you unchecked that box?
(guess I should reconfigure the installer,
so it is alway run without even asking?)

Andreas
_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user


_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user