Starcos

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Starcos

Peter Koch-3
>From the OpenSC Wiki:

> ==============================================================
>
> Starcos
>
> Is fully supported by OpenSC. It is tested very often (to be precise:
> Rainbow iKey 3000 which contains Starcos).
>
> Currently only Starcos SPK 2.3 is tested. If you have a newer version,
> please report back.
>
> G&D is a very nice company, their APDU manuals are public available, all
> you need to do is send an email asking for them, and they send you the
> latest version. This is great! Thanks G&D!
>
> ==============================================================

I do have a newer Starcos Card, namely SPK 3.3. What must I do to extend
OpenSCs Starcos support. Where do I get the above mentioned APDU manuals?

Here's some opensc-tool output:

$ opensc-tool -a
iso7816.c:98:iso7816_check_sw: Wrong length
iso7816.c:440:iso7816_select_file: returning with: Wrong length
card.c:763:sc_select_file: returning with: Wrong length
3b:9b:18:81:b1:fe:45:1f:07:80:67:04:12:b0:03:01:83:4c:81:05:18
iso7816.c:98:iso7816_check_sw: Wrong length
iso7816.c:440:iso7816_select_file: returning with: Wrong length
card.c:763:sc_select_file: returning with: Wrong length

I will add the ATR to card-starcos.c this weekend and let you know
what happens.

Peter

--
Lust, ein paar Euro nebenbei zu verdienen? Ohne Kosten, ohne Risiko!
Satte Provisionen f?r GMX Partner: http://www.gmx.net/de/go/partner
_______________________________________________
opensc-devel mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-devel
Reply | Threaded
Open this post in threaded view
|

Re: Starcos

Fabian Guter
Hi!

> I do have a newer Starcos Card, namely SPK 3.3. What must I do to extend
> OpenSCs Starcos support. Where do I get the above mentioned APDU manuals?

Hmm, are you sure about the OS version? After Starcos SPK 2.3 there has been
SPK 2.4, SPK 2.5 and Starcos 3.
Could you provide more information about the card you have?

Regards,
Fabian

_______________________________________________
opensc-devel mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-devel

attachment0 (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Starcos

Peter Koch-3

> > I do have a newer Starcos Card, namely SPK 3.3. What must I do to extend
> > OpenSCs Starcos support. Where do I get the above mentioned APDU
> manuals?
>
> Hmm, are you sure about the OS version? After Starcos SPK 2.3 there has
> been
> SPK 2.4, SPK 2.5 and Starcos 3.
> Could you provide more information about the card you have?

It's a prototype of the german Health Professional Card (aka elektronischer
Heilberufeausweise). I'm not sure about the version, but here's the ATR

3b:9b:18:81:b1:fe:45:1f:07:80:67:04:12:b0:03:01:83:4c:81:05:18

Peter

--
Telefonieren Sie schon oder sparen Sie noch?
NEU: GMX Phone_Flat http://www.gmx.net/de/go/telefonie
_______________________________________________
opensc-devel mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-devel