VERBOSE flag

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

VERBOSE flag

rmarc71

I'm using engine_pkcs11 0.1.8 and I can't get the VERBOSE
flag in the openssl config to make it verbose (I actually get
an error):

------------------------------------------------------------------
openssl_conf            = openssl_def

[openssl_def]
engines = engine_section

[engine_section]
pkcs11 = pkcs11_section

[pkcs11_section]
engine_id = pkcs11
MODULE_PATH = /path/to/pkcs11/lib.so
dynamic_path = /usr/local/openssl/lib/engines/engine_pkcs11.so
PIN = "mypin"
init = 1

------------------------------------------------------------------

Above works fine, but if I add a line with VERBOSE I get:

openssl s_server -engine pkcs11 -cert $CERT -key $TOKEN -accept 9443 -keyform engine
unable to load module (null)
can't use that engine
8237:error:80001401:lib(128):func(1):reason(1025):p11_load.c:68:
8237:error:260B806D:lib(38):func(184):reason(109):eng_table.c:161:
no engine specified
unable to load server certificate private key file

Without the VERBOSE line I get:

openssl s_server -engine pkcs11 -cert $CERT -key $TOKEN -accept 9443 -keyform engine
engine "pkcs11" set.
Using default temp DH parameters
Using default temp ECDH parameters
ACCEPT

If I go into the source and set verbose = 1 in engine_pkcs11.c I get what I need.
Just wondered if I'm doing something obviously wrong.

R. Marc
_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc-project.org/mailman/listinfo/opensc-user