dlname of opensc-pkcs11 shared library

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

dlname of opensc-pkcs11 shared library

Tarasov Viktor
Hi,

What can be the reason that there is no ".so" extention in the dlname of
the
opensc-pkcs11 and pkcs11-spy shared libraries?

I use the last trunk version. There are was no such problem two weeks ago.

Kinf wishes,
Viktor.

_______________________________________________
opensc-devel mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-devel
Reply | Threaded
Open this post in threaded view
|

Re: dlname of opensc-pkcs11 shared library

Andreas Jellinghaus-2
Hi Viktor,

did you use a snapshot or tar file or an svn checkout?

i.e. did you run bootstrap?
if so, what are your versions of autoconf, automake and libtool?
and could you test a snapshot or tar file as well?

could you compile once more your copy that causes the problem
generate a log file from that compile, and send the commands
for linking e.g. libopensc?

I suspect a autoconf/make/libtool issue, and that it only
happends if you bootstrap. but that is a wild guess, might
be wrong as well.

all I can say for now: all my systems are fine.
but then again those are all debian sarge, so this
is a mono culture :(

Regards, Andreas
_______________________________________________
opensc-devel mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-devel
Reply | Threaded
Open this post in threaded view
|

Re: dlname of opensc-pkcs11 shared library

Andreas Jellinghaus-2
In reply to this post by Tarasov Viktor
guess I found it.

could you try a fresh checkout, and delete or truncate
aclocal/libtool.m4, in it before running bootstrap,
configure and make?

guess adding that file was not a good idea, will undo
it anyway, but first it would be nice to have a confirmation
whether or not that was the source of the bug.

Regards, Andreas
p.s. sorry for the delay. please bug us, if we don't reply,
ask again and again. sometimes I have no idea, so I hope
that someone else answers it, and then I forget it and
don't notice that noone did. same happend today, but nils
reminded me (he has the same problem).
p.p.s. bugs in our bug database make sure we don't forget :)
p.p.p.s. but don't help much, as I don't look at it often
enough. think we need a weekly reminder email with all
open bugs.
_______________________________________________
opensc-devel mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-devel