pkcs11-spy dependency reader support

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

pkcs11-spy dependency reader support

Christopher Nebergall
I've been working for several hours to determine why I could use my soft
pkcs11 token through my application and through pkcs11-tool but not with
pkcs11-spy. Finally I've figured out that the problem was that I had no
smart card reader support compiled in. In the init methods for pkcs11
spy it counts all the readers available and if there are none it fails
and the init method returns out of memory.  Could the dependency be
noted in the documentation somewhere (or possibly removed?).  I'm not
trying to be negative, I just want to save someone else some debugging
time.  Thanks for all of your hard work.  

-Christopher



_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user
Reply | Threaded
Open this post in threaded view
|

Re: pkcs11-spy dependency reader support [u]

Andreas Jellinghaus-2
Hi Christopher,

sorry that pkcs11-spy caused you trouble.
With a quick look I can't find such a dependency in the code.
Maybe you know where the bogus code is and can
submit a patch?

Or can you open a bug report at http://www.opensc.org/opensc/
(-> newticket), so we keep track of this issue?

Thanks, Andreas
_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user
Reply | Threaded
Open this post in threaded view
|

Re: pkcs11-spy dependency reader support [u]

Christopher Nebergall
Or can you open a bug report at http://www.opensc.org/opensc/
(-> newticket), so we keep track of this issue?

Done.

http://www.opensc.org/opensc/ticket/33

-Christopher

_______________________________________________
opensc-user mailing list
[hidden email]
http://www.opensc.org/cgi-bin/mailman/listinfo/opensc-user